Today, I decided to install the Catalina Beta but after enrolling to the beta program, I encoutered this issue:

The requested version of macos is not available

The solution I found is to execute these two commands in the Terminal:

sudo defaults read /Library/Preferences/com.apple.SoftwareUpdate CatalogURL

sudo /usr/sbin/softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.15seed-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

After you execute the commands, reopen the Software Update section in the Preferences and install the Beta.